using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[“”](?=[^\]\[]*\])";
string substitution = @"""";
string input = @"“foobar” [tagname id=“1035” linked=“true”] “another” [tagname id=“1”]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}