$re = '/[“”](?=[^\]\[]*\])/m';
$str = '“foobar” [tagname id=“1035” linked=“true”] “another” [tagname id=“1”]';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;