use strict;
my $str = '“foobar” [tagname id=“1035” linked=“true”] “another” [tagname id=“1”]';
my $regex = qr/[“”](?=[^\]\[]*\])/mp;
my $subst = '"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";