re = /[“”](?=[^\]\[]*\])/m
str = '“foobar” [tagname id=“1035” linked=“true”] “another” [tagname id=“1”]'
subst = '"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result