using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\bA\d{1,2}$";
string input = @"Hex-A14
2-But-1,1,1,3,3-A5
Hep-A16
2-Pen-1,1,1,3,3-A5
Oct-A18
Dec-A22
Dod-A26
(2RS,5R)-Ment-2,6,6-A3
(2RS,5R)-Ment-2,6,6-B3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}