# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\bA\d{1,2}$"
test_str = ("Hex-A14\n"
"2-But-1,1,1,3,3-A5\n"
"Hep-A16\n"
"2-Pen-1,1,1,3,3-A5\n"
"Oct-A18\n"
"Dec-A22\n"
"Dod-A26\n"
"(2RS,5R)-Ment-2,6,6-A3\n\n"
"(2RS,5R)-Ment-2,6,6-B3")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.