re = /.*\bA\d{1,2}$/m
str = 'Hex-A14
2-But-1,1,1,3,3-A5
Hep-A16
2-Pen-1,1,1,3,3-A5
Oct-A18
Dec-A22
Dod-A26
(2RS,5R)-Ment-2,6,6-A3
(2RS,5R)-Ment-2,6,6-B3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end