const regex = new RegExp('.*\\bA\\d{1,2}$', 'gm')
const str = `Hex-A14
2-But-1,1,1,3,3-A5
Hep-A16
2-Pen-1,1,1,3,3-A5
Oct-A18
Dec-A22
Dod-A26
(2RS,5R)-Ment-2,6,6-A3
(2RS,5R)-Ment-2,6,6-B3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}