use strict;
my $str = 'Hex-A14
2-But-1,1,1,3,3-A5
Hep-A16
2-Pen-1,1,1,3,3-A5
Oct-A18
Dec-A22
Dod-A26
(2RS,5R)-Ment-2,6,6-A3
(2RS,5R)-Ment-2,6,6-B3';
my $regex = qr/.*\bA\d{1,2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}