#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*:$"
Local $sString = "Hi" & @CRLF & _
"I'm here:" & @CRLF & _
"London" & @CRLF & _
"UK" & @CRLF & _
"USA" & @CRLF & _
"Where are you:" & @CRLF & _
"here " & @CRLF & _
"there" & @CRLF & _
"what will you do:" & @CRLF & _
"something" & @CRLF & _
"somethin2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")