package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*:$`)
var str = `Hi
I'm here:
London
UK
USA
Where are you:
here
there
what will you do:
something
somethin2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}