re = /^.*:$/m
str = 'Hi
I\'m here:
London
UK
USA
Where are you:
here
there
what will you do:
something
somethin2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end