$re = '/^.*:$/m';
$str = 'Hi
I\'m here:
London
UK
USA
Where are you:
here
there
what will you do:
something
somethin2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);