import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*:$";
final String string = "Hi\n"
+ "I'm here:\n"
+ "London\n"
+ "UK\n"
+ "USA\n"
+ "Where are you:\n"
+ "here \n"
+ "there\n"
+ "what will you do:\n"
+ "something\n"
+ "somethin2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}