#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href="(.*)".*Контакты<\/a>"
Local $sString = "<li class="b-index-nav__item"><a href="/work/" class="b-index-nav__link">Портфолио</a></li><li class="b-index-nav__item"><a href="/jobs/" class="b-index-nav__link">Вакансии</a></li><li class="b-index-nav__item"><a href="/contact/" rel="nofollow" class="b-index-nav__link">Контакты</a></li>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")