const regex = /href="(.*)".*Контакты<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="(.*)".*Контакты<\\\/a>', 'g')
const str = `<li class="b-index-nav__item"><a href="/work/" class="b-index-nav__link">Портфолио</a></li><li class="b-index-nav__item"><a href="/jobs/" class="b-index-nav__link">Вакансии</a></li><li class="b-index-nav__item"><a href="/contact/" rel="nofollow" class="b-index-nav__link">Контакты</a></li>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}