using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(.*)"".*Контакты<\/a>";
string input = @"<li class=""b-index-nav__item""><a href=""/work/"" class=""b-index-nav__link"">Портфолио</a></li><li class=""b-index-nav__item""><a href=""/jobs/"" class=""b-index-nav__link"">Вакансии</a></li><li class=""b-index-nav__item""><a href=""/contact/"" rel=""nofollow"" class=""b-index-nav__link"">Контакты</a></li>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}