import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"(.*)\".*Контакты<\\/a>";
final String string = "<li class=\"b-index-nav__item\"><a href=\"/work/\" class=\"b-index-nav__link\">Портфолио</a></li><li class=\"b-index-nav__item\"><a href=\"/jobs/\" class=\"b-index-nav__link\">Вакансии</a></li><li class=\"b-index-nav__item\"><a href=\"/contact/\" rel=\"nofollow\" class=\"b-index-nav__link\">Контакты</a></li>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}