import re
regex = re.compile(r"href=\"(.*)\".*Контакты<\/a>")
test_str = ("<li class=\"b-index-nav__item\"><a href=\"/work/\" class=\"b-index-nav__link\">Портфолио</a></li><li class=\"b-index-nav__item\"><a href=\"/jobs/\" class=\"b-index-nav__link\">Вакансии</a></li><li class=\"b-index-nav__item\"><a href=\"/contact/\" rel=\"nofollow\" class=\"b-index-nav__link\">Контакты</a></li>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")