#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\-_]+(\.[\w\-_]+)*\@[\w\-_]+(\.[\w\-_]+)+$"
Local $sString = "" & @CRLF & _
"atipat.lorwongam@outlook.comunity.or.th" & @CRLF & _
"" & @CRLF & _
"domain...name@lollipop.com" & @CRLF & _
"" & @CRLF & _
"fail@mail.com" & @CRLF & _
"" & @CRLF & _
".failname2@email.co.de" & @CRLF & _
"" & @CRLF & _
"success@mail.co.in"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")