// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w\-_]+(\.[\w\-_]+)*\@[\w\-_]+(\.[\w\-_]+)+$").unwrap();
let string = "
atipat.lorwongam@outlook.comunity.or.th
domain...name@lollipop.com
fail@mail.com
.failname2@email.co.de
success@mail.co.in";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}