const regex = /^[\w\-_]+(\.[\w\-_]+)*\@[\w\-_]+(\.[\w\-_]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w\\-_]+(\\.[\\w\\-_]+)*\\@[\\w\\-_]+(\\.[\\w\\-_]+)+$', 'gm')
const str = `
atipat.lorwongam@outlook.comunity.or.th
domain...name@lollipop.com
fail@mail.com
.failname2@email.co.de
success@mail.co.in`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}