import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w\\-_]+(\\.[\\w\\-_]+)*\\@[\\w\\-_]+(\\.[\\w\\-_]+)+$";
final String string = "\n"
+ "atipat.lorwongam@outlook.comunity.or.th\n\n"
+ "domain...name@lollipop.com\n\n"
+ "fail@mail.com\n\n"
+ ".failname2@email.co.de\n\n"
+ "success@mail.co.in";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}