package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\-_]+(\.[\w\-_]+)*\@[\w\-_]+(\.[\w\-_]+)+$`)
var str = `
atipat.lorwongam@outlook.comunity.or.th
domain...name@lollipop.com
fail@mail.com
.failname2@email.co.de
success@mail.co.in`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}