using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+\s?\w+ ?";
string input = @"Genius Mushroom – Lions Mane, Cordyceps and Reishi – Immune System Booster & Nootropic Brain Supplement – Wellness Formula for Natural Energy, Stress Relief, Memory & Liver Support, 90 Veggie Pills";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}