re = /^\w+\s?\w+ ?/m
str = 'Genius Mushroom – Lions Mane, Cordyceps and Reishi – Immune System Booster & Nootropic Brain Supplement – Wellness Formula for Natural Energy, Stress Relief, Memory & Liver Support, 90 Veggie Pills'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end