// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w+\s?\w+ ?").unwrap();
let string = "Genius Mushroom – Lions Mane, Cordyceps and Reishi – Immune System Booster & Nootropic Brain Supplement – Wellness Formula for Natural Energy, Stress Relief, Memory & Liver Support, 90 Veggie Pills";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}