$re = '/^\w+\s?\w+ ?/m';
$str = 'Genius Mushroom – Lions Mane, Cordyceps and Reishi – Immune System Booster & Nootropic Brain Supplement – Wellness Formula for Natural Energy, Stress Relief, Memory & Liver Support, 90 Veggie Pills';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);