import re
regex = re.compile(r"^\w+\s?\w+ ?", flags=re.MULTILINE)
test_str = "Genius Mushroom – Lions Mane, Cordyceps and Reishi – Immune System Booster & Nootropic Brain Supplement – Wellness Formula for Natural Energy, Stress Relief, Memory & Liver Support, 90 Veggie Pills"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")