using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bis(\w*)\(\$([^()]*)\)\s*===\s*false\b";
string input = @"if (isset($data) === false && is_null($data) === false && is_array($data) === false) {";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}