re = /\bis(\w*)\(\$([^()]*)\)\s*===\s*false\b/m
str = 'if (isset($data) === false && is_null($data) === false && is_array($data) === false) {'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end