// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bis(\w*)\(\$([^()]*)\)\s*===\s*false\b").unwrap();
let string = "if (isset($data) === false && is_null($data) === false && is_array($data) === false) {";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}