package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bis(\w*)\(\$([^()]*)\)\s*===\s*false\b`)
var str = `if (isset($data) === false && is_null($data) === false && is_array($data) === false) {`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}