$re = '/\bis(\w*)\(\$([^()]*)\)\s*===\s*false\b/m';
$str = 'if (isset($data) === false && is_null($data) === false && is_array($data) === false) {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);