#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){(?>[^{}]|(?R))*\}"
Local $sString = "Why is preg_match_all not working?" & @CRLF & _
"$pattern = '/\{(?:[^{}]|(?R))*\}/';" & @CRLF & _
"$result = 161240 characters" & @CRLF & _
" if (preg_match_all($pattern, $result, $matches)){ {" & @CRLF & _
" echo 'Success';" & @CRLF & _
" } else {" & @CRLF & _
" echo 'Not working';" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")