$re = '/{(?>[^{}]|(?R))*\}/m';
$str = 'Why is preg_match_all not working?
$pattern = \'/\\{(?:[^{}]|(?R))*\\}/\';
$result = 161240 characters
if (preg_match_all($pattern, $result, $matches)){ {
echo \'Success\';
} else {
echo \'Not working\';
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);