import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?>[^\\{\\}]|(?R))*\\}";
final String string = "Why is preg_match_all not working?\n"
+ "$pattern = '/\\{(?:[^{}]|(?R))*\\}/';\n"
+ "$result = 161240 characters\n"
+ " if (preg_match_all($pattern, $result, $matches)){ {\n"
+ " echo 'Success';\n"
+ " } else {\n"
+ " echo 'Not working';\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}