re = /{(?>[^{}]|(?R))*\}/m
str = 'Why is preg_match_all not working?
$pattern = \'/\\{(?:[^{}]|(?R))*\\}/\';
$result = 161240 characters
if (preg_match_all($pattern, $result, $matches)){ {
echo \'Success\';
} else {
echo \'Not working\';
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end