using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{(?>[^{}]|(?R))*\}";
string input = @"Why is preg_match_all not working?
$pattern = '/\{(?:[^{}]|(?R))*\}/';
$result = 161240 characters
if (preg_match_all($pattern, $result, $matches)){ {
echo 'Success';
} else {
echo 'Not working';
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}