# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.0*$|(\.\d*[1-9])0+$/#$1/gm;t' <<< "0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002"