package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.0*$|(\.\d*[1-9])0+$`)
var str = `0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002`
var substitution = "#$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}