#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.0*$|(\.\d*[1-9])0+$"
Local $sString = "0" & @CRLF & _
"0.0" & @CRLF & _
"0.00" & @CRLF & _
"1.0" & @CRLF & _
"10.00" & @CRLF & _
"100" & @CRLF & _
"200.010" & @CRLF & _
"200.01023000" & @CRLF & _
"200.100" & @CRLF & _
"200.1002"
Local $sSubst = "#$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)