use strict;
my $str = '0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002';
my $regex = qr/\.0*$|(\.\d*[1-9])0+$/mp;
my $subst = '#$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";