import Foundation
let pattern = #"\.0*$|(\.\d*[1-9])0+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#$1"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)