const regex = /(?<!\d)\d{1,2}(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)\\d{1,2}(?!\\d)', 'gm')
const str = `This expression finds 1 or 2 digits that are not enclosed with any other digit, so it will find a match in \`a12b\`, \`1\`, \`12\`, \`a_1_b\`, \`x_23\` strings.
123
1233333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}