import re
regex = re.compile(r"(?<!\d)\d{1,2}(?!\d)", flags=re.MULTILINE)
test_str = ("This expression finds 1 or 2 digits that are not enclosed with any other digit, so it will find a match in `a12b`, `1`, `12`, `a_1_b`, `x_23` strings.\n\n"
"123\n"
"1233333")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")