$re = '/(?<!\d)\d{1,2}(?!\d)/m';
$str = 'This expression finds 1 or 2 digits that are not enclosed with any other digit, so it will find a match in `a12b`, `1`, `12`, `a_1_b`, `x_23` strings.
123
1233333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);