use strict;
my $str = 'This expression finds 1 or 2 digits that are not enclosed with any other digit, so it will find a match in `a12b`, `1`, `12`, `a_1_b`, `x_23` strings.
123
1233333';
my $regex = qr/(?<!\d)\d{1,2}(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}