#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,3}[.,]\d+[, -]+\d{1,3}[.,]\d+"
Local $sString = "38.622446, -76.941988" & @CRLF & _
"53.545265,-113.486355" & @CRLF & _
"17.41586,78.48162" & @CRLF & _
"58,4272 15,6001" & @CRLF & _
"" & @CRLF & _
"1234.4567.8910" & @CRLF & _
"1234-4567-8910" & @CRLF & _
"1234 4567 8910" & @CRLF & _
"1234 4567 8910.2 players ready" & @CRLF & _
"Cobalion-1234 4567 8910-3players waiting"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")