# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{1,3}[.,]\d+[, -]+\d{1,3}[.,]\d+"
test_str = ("38.622446, -76.941988\n"
"53.545265,-113.486355\n"
"17.41586,78.48162\n"
"58,4272 15,6001\n\n"
"1234.4567.8910\n"
"1234-4567-8910\n"
"1234 4567 8910\n"
"1234 4567 8910.2 players ready\n"
"Cobalion-1234 4567 8910-3players waiting")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.